Wowpedia
Advertisement
Wowpedia
237,101
pages
Forums: Village pump → Merger issues
(This topic is archived. Please do not edit this page!)

Please add any issues discovered after the merger in this list, in hopes they can be fixed. Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 01:50, 1 August 2013 (UTC)

Issues

Issues Curse need to fix (config settings, extensions)

  • Hydra puts all of the UI (the netbar, search, the nav links on the left-hand side) before the content in text mode browsers (elinks, search engine bots, users with css disabled) - Vector puts content first and UI later. Compare these 80x48 viewports: Wikipedia, Wowpedia
    • this is due to the hydra skin, it will not be changed. We support IE8+, FF5+, Chrome, Safari, and Opera. - Smokie (talk) 18:49, 1 August 2013 (UTC)
      • I would urge reconsidering. This isn't about moving content around in modern browsers -- more for making it make the most sense to search engine bots. Does seeing the same ~50 lines of boilerplate links on every single page before getting to the actual content look good from their end? --k_d3 20:49, 1 August 2013 (UTC)
      • I would echo this. It's a pretty big usability loss to do it this way, and that's pretty clear from all the documentation that I've seen. --Sky (talk) 20:21, 11 August 2013 (UTC)
  • Validator errors (excluding ad-caused):
    • Bogus (currently blank) value for Manual:$wgAppleTouchIcon
    • Social widget not escaping &s
    • Social widget images without alt= attributes
    • Various curse-footer issues
  • Logging in via the API (for bots) doesn't work. Upstream documentation for api logins: API:Login
    • Bots can login as long as they follow redirects. WIth our central auth service, some of the bots freak out when they get redirected due to the auth service. - Telshin (talk) 19:34, 2 August 2013 (UTC)
    • Some notes: the initial redirect chain from the initial api.php?action=login ends up setting a cookie on wowpedia's domain; you need to re-issue the initial api request with that cookie manually (302 redirects must send a GET request; api.php login requests require POSTs); subsequent login API requests have a tendency to return 302 status codes and redirect to /api.php; ignore the redirects and treat those as 200 replies. If your bot still has a display name change credit, the login success API response body/status code is hijacked to redirect you to Special:DisplayName; you can ignore this and use the issued cookies. — foxlit (talk) 20:35, 2 August 2013 (UTC)
      • Any request to http://www.wowpedia.org/api.php gets a 302 response redirecting to http://wowpedia.org/api.php; the response body is the actual API response. There's a rather silly bit of domain name canonisation logic calling header('Location: ...'); somewhere before handling the request as if nothing had happened; API requests should really not be redirected in this fashion. — foxlit (talk) 23:34, 11 August 2013 (UTC)
  • hydra.css is loaded after ResourceLoader-provided site styles, and overrides some of them; should be loaded before (if at all -- isn't it included in the ResourceLoader output?). This causes the Curse netbar to clip the Wowpedia logo.
  • Changing your email address via Special:CurseChangeEmail does not send a verification email (no error message appears; no email is received).
    • This is working as intended from the Wiki team's code side, however, the bug appears to be in the CurseAuth side. I've sent a ticket upstream to deal with the problem. - Telshin (talk) 15:44, 5 August 2013 (UTC)
      • The ticket is with the auth team now. - Telshin (talk) 14:05, 7 August 2013 (UTC)
  • Clicking "Resend Verification Email" on Special:CurseEmailAuth results in an error: "There was a fatal error resending a new verification email. Please try again in a few hours otherwise please report this error to an administrator to have your email address manually verified." Waiting a few hours does not help.
    • Which user reported this? - Telshin (talk) 15:45, 5 August 2013 (UTC)
    • This appears to be an issue with the CurseAuth service and has been reported to the appropriate team. Azxiana (talk) 17:47, 5 August 2013 (UTC)
      • The ticket is with the auth team now. - Telshin (talk) 14:05, 7 August 2013 (UTC)
  • The wiki sometimes fails to recognize that a user is logged in, and serves logged-out content instead. The error is intermittent: merely refreshing the page, without logging in again, is usually sufficient to appear to be logged in again.
    • From the description, this sounds like a MediaWiki error from upstream. I'm not sure if it's fixed even on the en.wikipedia servers (which are on more-or-less weekly builds). --Sky (talk) 20:19, 11 August 2013 (UTC)
    • The last time this was happening, one of the caches was out of sync and didn't recognize the login cookies. --k_d3 20:56, 11 August 2013 (UTC)
  • Adding <meta itemprop="author" content="Gamepedia" > to every page is inappropriate.
  • Special:UserLogin is styled badly: boxes need padding, headers are gray-on-gray, some element borders are white on a dark skin, and the page wraps horribly if the browser window is not wide enough.
    • There are stopgap fixes for some of these problems in MediaWiki:hydradark.css. In the long run, this really should be addressed elsewhere. — foxlit (talk) 20:08, 12 August 2013 (UTC)
  • Users who had their usernames changed as part of the move to a curse account had their pages ostensibly moved. Special:BrokenRedirects suggests otherwise.
  • The 'updated since your last visit' text in page histories no longer displays on edits where a sub-section of the article was edited, or where a comment has been made.
  • The <math> command is broken. Examples can be found here.
  • The "identify cats" will be asked before submitting changes see you are submitting "external links" even when you have no edited/add external links to an article.

Fixed/deferred issues

  • Special:SpecialPages, top lines are messed up (fixed)
  • Adding an article on the watchlist throws the star icon far down into the article moving everything down (fixed)
  • Auto-refresh image at Special:RecentChanges is not showing. Special:RecentChanges has a option to auto-refresh. When it reloads it shows File:Progressbar.gif, instead of showing the progress bar it shows another image that says "AJAX operation in progress". — SurafbrovWowpedia's wiki representative T / C 06:02, 1 August 2013 (UTC) — (fixed)
  • For the option to share of each article, the sharing arrow is placed wrong, its on top of the "r" in "Share". (fixed)
  • Upload multiple images no longer available (as an alternative, the new editor widget ostensibly allows multiple uploads thanks to MsUpload being added.)
    • Multi-upload is out of date and broken. Until it is updated/patched, msupload is our only options. - Smokie (talk) 18:49, 1 August 2013 (UTC)
  • There are two divs with the id="footer", one built-in to mediawiki, and one from Curse (change the Curse one!)
    • This will be fixed on next deploy - Smokie (talk) 18:49, 1 August 2013 (UTC)
  • Namespace aliases didn't carry over (e.g. WP: ->Wowpedia)
    • Will be fixed soon. - Smokie (talk) 18:49, 1 August 2013 (UTC)
  • When you edit a page and you submit it, a sharing box that provides you to share to your friends about your edit. Pressing "Never again", "No thanks", or "Done" does not close the box/make the box disappear, vanish, etc. The box will not go away, for every article you are at, apart from pages you can't edit like Special pages, settings, etc. This is happening in firefox, not sure about other browsers.
    • It appears your personal javascript is causing your issue. We cannot reproduce this unless we turn off all javascript. We are working on creating the ability to turn off all social functions for you guys. - Smokie (talk) 18:49, 1 August 2013 (UTC)
    • You can turn this off in Special:Preferences#mw-prefsection-misc
  • Special:AllSites is 500ing
    • Looking into why this is 500ing. - Smokie (talk) 18:49, 1 August 2013 (UTC)
  • wikitables need formatting for darkhydra
  • The embedded vplayer no longer functions, example.
    • We will look into it. Best option might be to use embedvideo. - Smokie (talk)
      • VideoLink should function correctly shortly; leave pages as is. — foxlit (talk) 21:04, 1 August 2013 (UTC)
  • Simplesearch is frequently popping up two suggestion windows instead of just one
  • "Sorry, there was a problem merging your account into our central database. Please try again later or contact an administrator for assistance. [Error #1004 - User Merge Add]"
    • One possible cause: not having an email address attached to the wiki account while trying to create a corresponding curse account. Contact Curse. — foxlit (talk) 18:44, 2 August 2013 (UTC)
  • Most curse account-related special pages, like Special:CurseChangePassword, are skinned for a light skin.
    • This should be fixed - Telshin (talk) 14:43, 5 August 2013 (UTC)
  • The parser is screwing up lists inside divs/tables, ending the div/table cell before the list - see any hlisted-navbox (notably: {{Patches}}, which is also temporarily working around the problem) - test cases at User:Kaydeethree/parsertest
    • Some of this is due to the move to 1.19, we need more examples to isolate this down - Smokie (talk) 18:49, 1 August 2013 (UTC)
    • hlist-issues in general (at the time of this writing, line-break:nowrap is turned off to work around some of them. It will go back on eventually)
      • Looks like due to 1.19. Can you be more descript. - Smokie (talk) 18:49, 1 August 2013 (UTC)
        • This is most likely a server configuration issue: check that Tidy is actually installed and accessible using the binary specified by $wgTidyBin. The "Tidy found serious XHTML errors" html comment that appears on all wiki pages suggests that the wiki isn't actually able to run it, despite $wgUseTidy being turned on. — foxlit (talk) 17:11, 15 August 2013 (UTC)
    • This should be fixed now, though you might have to purge any pages that still exhibit this behavior. — foxlit (talk) 14:59, 16 August 2013 (UTC)
  • Search Icon is slightly missed-placed, needs to be moved up a few pixels.
    • Looks fine to me. Screenshot it? — foxlit (talk) 14:59, 16 August 2013 (UTC)
  • Special:Editcount has a white background; Hard to read unless highlighted.
    • Extension bug, really -- it hardcodes the background color for no good reason. — foxlit (talk) 14:59, 16 August 2013 (UTC)

Questions

Display names

Main article: Forum:Display names

Does our User names have to appear next to our name on all changes, and our user pages? ie "Coobra (User:Coobra)" Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 01:50, 1 August 2013 (UTC)

I don't like it, especially since my Curse account name is different from the one I've been using here for years. However, it's been useful so far for keeping track as we become used to the changes. After people have had awhile to adjust, then I think the (User:<name>) ought to be hidden. -- Alayea (talk / contrib) 02:30, 1 August 2013 (UTC)
We're still sorting something out on that front. For future reference, at the time of this post, [[User:Kaydeethree]] is displaying "Kaydeethree (User:Kaydeethree)". For now, you can add to your Special:MyPage/hydradark.css the following css rule:
.dnUser {display: none}
This turns "Kaydeethree (User:Kaydeethree)" to "Kaydeethree" everywhere on the wiki, including the <h1> headers on user pages, and on recent changes. We are going to come up with something more permanent, because I don't like the current situation at all. --k_d3 02:51, 1 August 2013 (UTC)
Foxlit's rolled out a gadget that makes things a bit more sane. To enable it, go to Special:Preferences#mw-prefsection-gadgets and enable the "Reformat display names and User namespace links" option. --k_d3 00:25, 2 August 2013 (UTC)
Just a note here, if you are typing a link to your userspace (i.e. your signature) and you wish it to display only your display name, you can add a space after, example: [[User:Wynthyst|Wynthyst ]] displays as Wynthyst rather than Wynthyst. -- Wynthyst User Wynthyst sig icon.png talk 06:21, 1 August 2013 (UTC)
More info on the display names situation is at Forum:Display names. --k_d3 18:36, 2 August 2013 (UTC)

Edit widget

The editing UI keeps flashing from the old version to a bulky one that I do not like. How does one keep the old version?--SWM2448 04:16, 1 August 2013 (UTC)

Special:Preferences#mw-prefsection-editing - turn off everything in the "Beta features" and "Labs features" section. Alternately, you could turn off "Show edit toolbar (requires JavaScript)" in the "Advanced options" section and leave the new one on. I'm gonna try out the new UI for a while. Because of the way the wiki's generating pages, most of the site javascript gets loaded last, so there's a noticeable (~0.5 sec) delay between main page load and the javascript pass.--k_d3 04:23, 1 August 2013 (UTC)
Interesting... hitting cancel in that new editor saves the work anyway =/ Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 04:33, 1 August 2013 (UTC)

MsUpload

I'm liking the MsUpload feature, though I do find it slightly inconvenient, since you can't select a license or add a description at the time of upload. Don't suppose we have any way of playing with that feature do we? Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 05:26, 1 August 2013 (UTC)

My cursory glance at the extension page upstream indicates that others are asking for those things too. --k_d3 20:39, 1 August 2013 (UTC)

User Page

My user page seems to have been deleted along with its associated discussion page. Was this expected as part of the merge? Aliok (talk) 20:21, 1 August 2013 (UTC)

What was your username before the merge? --k_d3 20:38, 1 August 2013 (UTC)
Your page and contribs are under User:Aliok73471. Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 21:27, 1 August 2013 (UTC)
Thank you for getting it back for me, Coobra. (And thank you Kaydeethree, too.) (edited because I forgot to sign) Aliok (talk) 22:59, 1 August 2013 (UTC)
Coobra, could you restore my user page too? the actual name is Petrovic72431. I'd like to be just "Petrovic" again. --User:Petrovic (talk) 14:37, 5 August 2013 (UTC)
Petrovic72431 doesn't exist. Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 21:28, 5 August 2013 (UTC)
I got my user talk and contributions back but now, I lost my old nick :S. I have to check if there's a way to recover it. --Admin Petrovic (talk) 18:48, 6 August 2013 (UTC)
I have the same problem, User:A'noob has been deleted and i am stuck with User:User_56419
trully a mess and cannot fix it. Any ideas ?
IconSmall Hamuul.gif Loremaster A'noob, Arch Druid of the Noobhoof Clan (talk/contribz) 17:58, 12 August 2013 (UTC)
It is a little annoying, but it seems you're now under User:Anoob. Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 03:23, 14 August 2013 (UTC)
I am also having this issue. My old name, User:SDKPhoenix, is no longer there. I would appreciate it if someone could restore my old stuff. Thanks! Nevermind, it got renamed, just had to log in to merge it.Sdkphoenix (talk) 01:28, 14 August 2013 (UTC)
Same problem (User:Zeal71374) -- well more so I guess. Curse name is zealvurte, I was Zealvurte on here before the move to Curse, you kindly renamed me Zeal and moved my userspace over to that, the merger caused me to be Zeal71374 apparently (which was done it a way that doesn't show the userspace move from Zeal) beause there's a Curse user already called Zeal, I chose the name Zealvurte when prompted, and ofc it didn't move any of my userspace over to Zealvurte... fix please. -- Zeal (T/C)  15:03, 18 August 2013 (UTC)
Done. Snake.gifSssssssssssssssssssssssss Coobra sig3.gifFor Pony! (Sssss/Slithered) 23:02, 19 August 2013 (UTC)

Other languages

Guys, have you consider to check the wowpedia subdomains too?, we have some design bugs in the infobox templates in the spanish wowpedia that need to be fixed... --Petrovic (talk) 13:38, 4 August 2013 (UTC)

I saw vlink was fixed here (example) but not in the spanish wowpedia (example). Any chance to fix it too? --Petrovic (talk) 01:27, 12 August 2013 (UTC)
VideoLink has now been added to the Spanish wiki, so this issue should be resolved. -- Wynthyst User Wynthyst sig icon.png talk 20:55, 14 August 2013 (UTC)
Thank you! ;) --Petrovic (talk) 18:37, 15 August 2013 (UTC)

Edit Conflicts

There doesn't seem to be a warning anymore for edit conflicts; Taohinton and I both edited the same section of the same page at the same time, and rather than giving me a warning about that it simply replaced Taohinton's version with my own - see the recent history for  [Rascal-Bot]. -- Dark T Zeratul (talk) 20:51, 28 August 2013 (UTC)

Similarly, I just made an edit to Quest achievements/Pandaria removing Alliance  [Hordebreaker] and Horde  [Darkspear Revolutionary]. However, I took my time saving the edit, and in the meanwhile Zdroid made the same edit himself. However, when I saved my edit, I did not get any conflict warning, and the page reloaded normally; presumably this is because the two edits were identical, or because my edit no longer changed the current page. It was only when I checked my watchlist that I found Zdroid credited for the edit a few minutes earlier - mine was not saved. Of course, this behaviour may already have been the case before the merger, since I've not tried this before ;) -- Taohinton (talk) 22:39, 16 September 2013 (UTC)

Search is Broken?

Just chiming in to say that the search seems completely broken, at least on my end. Try searching for 'sword' - you get ten results, one of which is an icon completely unrelated. RustyShackles (talk) 09:31, 11 September 2013 (UTC)

Advertisement