Talk:WoWBench/Talk

From Wowpedia
Jump to: navigation, search

  Icon-edit-22x22.png Start a new discussion!    


  • Please sign your posts with --~~~~, which automatically expands to your user name and a time stamp.

Welcome!

Welcome to the hairy Lua nest, folks. I started throwing this project together one Wednesday morning when the servers were down for maintenance, on a whim, really, but it turned out that it helped me so much with developing my AddOns that I expanded it to be more generally useful, and now I've dumped it in the hands of the WoW AddOn developer community as a whole. I hope it'll be as useful as you as it has been to me! --Mikk 08:17, 16 June 2006 (EDT)

  • Puuh, got WoWBench/FAQ and WoWBench/Getting started done, I think. Comments go on their respective talk pages. (I need to l2type, or something you'd like me to explain in more detail)   --Mikk 11:00, 16 June 2006 (EDT)

Branching off 1.11

I'm branching off 1.11 in the SVN. It's a bit early to do it since it's still in Alpha and lots of 1.10 work remains, but it's a chance to show what it's actually useful for, since the PTRs are down more than not! --Mikk 12:56, 16 June 2006 (EDT)

TEXT(str)

Quick question. What's the point behind the TEXT(str) function? --Tarog 19:04, 16 June 2006 (EDT)

Nothing afaik in English language clients. Supposed to have something to do with localization I think. --Mikk 19:56, 16 June 2006 (EDT)

WoWBench/Progress

I put together a script to parse the [DUD], [HALF], [FULL] tags in api.lua (that Tarog hacked in for us - thanks!) and output WoWBench/Progress. Lots of red in that page but we have to keep in mind that the majority of mods only use a fraction of the actual API. --Mikk 19:22, 19 June 2006 (EDT)

Going public for real

The only reason I see now for holding back on going public for real (posting on addon sites) is currently the two missing semi-important pages (WoWBench/Documentation and WoWBench/Extending). Are you guys more or less of the same opinion or do you see any other reason to delay opening the flood gates? --Mikk 19:28, 19 June 2006 (EDT)

I don't see any reason to hold back. --Tarog 00:59, 20 June 2006 (EDT)
It's up on wowinterface.com now. Not sure I'll put it up anywhere else myself. Just becomes a hassle to keep upgraded =)   --Mikk 11:30, 26 June 2006 (EDT)

Speeding up by keeping a copy of FrameXML?

I just did some experiments with keeping a backup copy of the entire environment as it looks after FrameXML is loaded.

With FrameXML already precompiled, I get the following on my box:

  • Regular loading process: 12 seconds
  • Regular loading process + make a backup: 20 seconds (ow)
  • Replace global environment with backup (what you'd do instead of restarting): 12 seconds

... doh. --Mikk 19:45, 4 July 2006 (EDT)

Precompiled win32 Lua binaries including bitlib!

Cladhaire put together a win32 Lua executable including a bitlib DLL, which I promptly snarfed and put up on sourceforge.net. Highly recommended for full compatibility with WoW :-)   --Mikk 18:04, 19 July 2006 (EDT)

Err. Don't use this. It takes over a minute to fire up WoWBench with it. The standard Lua distrib takes about 10 seconds on my box. I'll poke Clad and see what might be up. --Mikk 19:45, 24 July 2006 (EDT)
Whoot! Cladhaire spared no effort and now gave us a version that's actually FASTER than the standard LuaBinaries package! WoWBench now loads in ~9 seconds on my box compared to ~11-12 with the standard package. AND it includes the bitlib! Yay! :-) --Mikk 08:51, 27 July 2006 (EDT)

FYI: I've done similar for WoW 2.0 using Lua 5.1.1 with all 5.0 compatibility options turned off [1]. It includes bitlib as well as a few blizzard-specific functions (strtrim, strconcat, strsplit & strjoin) and also creates the global aliases to library functions (e.g. strfind for string.find). The precompiled binaries were built using MSVC, so they squeeze a tiny bit more performance out of windows. ;) --Cogwheel 13:31, 30 November 2006 (EST)

Starting up WoWBench?

How exactly do i start up WoWbench... the EXE doesn't work, it says "C:\wowbench\wow\wow.exe is not a valid Win32 application", idk what to do so any help would be fantastic

--Thursday 20:24, 29 November 2006 (EST)

Reading the documentation would be a nice start... Cogwheel 13:24, 30 November 2006 (EST)
Try helping me dumbass, no shit i read the documentation, I did it all and this DOESN'T WORK --Thursday 00:29, 1 December 2006 (EST)
If you read the documentation, you wouldn't be trying to run wow.exe... Here's the second section of the link above. --Cogwheel 16:39, 1 December 2006 (EST)
I agree. I had the same issue. After reading the documentation I had apparently missed making a complete copy of the config-dist.lua and re-naming it to config.lua. I also had WoW installed to a different directory than C:\Program Files\World of Warcraft\... After editing the content of the config-dist.lua (before copying it) to point at the proper WoW location, running the command C:\wowbench\lua wowbench.lua -f launched it exactly like in the documentation. Considerthis 17:05, 17 June 2008 (AKST)
Here is my solution to problems like this since some people seem to be unable to read documentation [[2]. Now all you have to do is run the .bat file and it will load WoWBench for you. Yes I do realise that it is located under the patches for WoWBench, but maybe it should be included into the project --EKJ 14:33, 22 September 2008 (UTC)

Loading WoW 2.0 addons

Hi. My problem might not be with WoWBench in particular but I hope you can give me some direction. I am trying to run my addon on it so I can develop it ouside of wow. It has 2 dependencies: Chronos and GetDKP which are so old I had to change them myself. They currently work in WoW live and TBC without problem.

After a successful install everything runs great. When I try to load Chronos for my first dependency however, I get:

---[.../AddOns/Chronos/Chronos.toc]

ERROR: ./wow/Interface/AddOns/Chronos/Chronos.lua:117: unexpected symbol near `#' Entering debugger. Use "help" for help.


It doesn't seem to recognize the table length operator (#). I tried GetDKP and it loads great but when I try to run it I get:


[I am alive!] --------------------------------------------------------

Use "help" for help

cmd> /dkp Mage

ERROR: ./wow/Interface/AddOns/GetDKP/GetDKP.lua:11: attempt to call field `gmatch' (a nil value) Entering debugger. Use "help" for help.


Doesn't recognize string.gmatch. Both changes are part of the 5.0 LUA version but I can't get them to work.


What do I need to do to make this work? I tried using the lua.exe and luac.exe you packaged with wowbench. I tried downloading the binaries from http://luabinaries.luaforge.net/ version 5.0.3. Same results.


I even tried to compile the lua outside of wowbench (C:\lua Chronos.lua) and it gives me same error message :(

What am I missing? *pulls hair out*

--Alow 13:59, 26 December 2006 (EST)

The problem is simply that WoWBench isn't WoW 2.0 compatible yet. It will be. In time. But isn't today.   --Mikk (T) 16:59, 26 December 2006 (EST)

wowbench.lua problem - Linux (Fedora Core 6 64bit)

Hi there,

I have just started working on addons, so I don't have much of lua experience (although I have some xml and quite a lot of java experience) :) I wanted to test my first addons with wowbench under linux (FedoraCore 6 64bit).


I've done everything according to the documentation I've found on this page (wowwiki). I have lua 5.1.1 installed and wowbench-1.12.0.a2

my problem is that whenever I try to launch wowbench.lua it gives me such error:

       lua: wowbench.lua:XX: attempt to call a table value
       stack traceback:
       wowbench.lua:XX: in main chunk

where XX is the line number in .lua file

does anyone experienced similar problem under linux ?

best regards, Hamgryz

--Hamgryz 09:32, 4 January 2007 (EST)


Never mind my questions.... ;] It turned out that it works fine with lua 5.0.1 :)

I will leave this here however just in case someone else having same issue.

regards, Hamgryz

WoWBench not working on MacBook

I followed all the installation guides, etc., on wowwiki.com, but when I try to issue the command "lua wowbench.lua -f" I get the following:

lua: wowbench.lua:13: attempt to call global 'loadlib' (a nil value)
stack traceback:
wowbench.lua:13: in main chunk
[C]: ?

I am brand new to all of this, but I gather the problem is at line 13 of the code for the wowbench.lua file. That code is: luaopen_bit = loadlib("bitlib.dll", "luaopen_bit");

Another poster on this site seemed to have a similar problem that was resolved by reverting to an older version of Lua. However, I would rather not use an older version. It is my opinion that, if there is an incompatibility, it is WoWBench's responsibility to step up to the plate and update to the current version of Lua.

-- Mortimir 04:59, 22 February 2008 (UTC)

Wowbench _MacOs_Lua

I am lost trying to find a source of both Wowbench, lua that work in MacOsX. So far I have lua that works in MacOsX but no WoWbench. Can anyone help?

-- Fscoggins (talk) 08:18, May 2, 2010 (UTC)

Wowbench _MacOs_Lua

I am lost trying to find a source of both Wowbench, lua that work in MacOsX. So far I have lua that works in MacOsX but no WoWbench. Can anyone help?

-- Fscoggins (talk) 08:18, May 2, 2010 (UTC)